How to fix Spotlight issues in macOS 15 Sequoia
Spotlight stopped working after I upgraded to macOS 15 Sequoia. I noticed the error when I can no longer find installed apps with just a few keystrokes; I know spotlight is more than just an app launcher, but that’s my primary use, Command+Space and a few initial letters of the appname, to launch apps directly.
I found many articles online on how to fix it with mdutil, but none of them can fix my problem. Ended up having to try all the relevant options in the manual page and fixed it. I had a rather large 40TB external disk with many files, took a while to delete and rebuild the index.
I had to fix it by removing Spotlight index directories, I did it to all the key ones indexed by the system and all my mounted volumes.
sudo mdutil -X /
sudo mdutil -X /System/Volumes/Data
sudo mdutil -X /System/Volumes/Preboot
sudo mdutil -X /Volumes/Macintosh\ HD/
sudo mdutil -X /Volumes/<To each of the mounted volumes you have>
If the above didn’t solve it for you, the fuller solution involves turning off System Integrity Protection (SIP) with csrutil
, stopping mds
daemon, deleting indexes, enable spotlight, etc:
csrutil disable
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo mdutil -Ea
sudo mdutil -X /
sudo mdutil -X /System/Volumes/Data
sudo mdutil -X /System/Volumes/Preboot
sudo mdutil -X /Volumes/Macintosh\ HD/
sudo mdutil -X /Volumes/<Each mounted volume>
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo mdutil -i on /
sudo mdutil -i on /System/Volumes/Data
sudo mdutil -i on /System/Volumes/Preboot
csrutil enable
Originally published at https://evolvingviews.com on October 18, 2024.